I recently hired into a data analytics team for a hospital, and we don’t have a style guide. Lots of frustration from folks working with legacy code…I thought putting together a style guide would help folks working with code they didn’t write, starting with requiring a header for SQL scripts first as low hanging fruit.

Or so I thought.

My counterpart over application development says that we shouldnt be documenting any metadata in-line, and he’d rather implement “docfx” if we want to improve code metadata and documentation. I’m terrified of half-implementing yet another application to further muddy the waters–i’m concerned it will become just one-more place to look while troubleshooting something.

Am I going crazy? I thought code headers were an industry standard, and in-line comments are regarded as practically necessary when working with a larger team…

  • TehPers@beehaw.org
    link
    fedilink
    arrow-up
    10
    ·
    edit-2
    11 months ago

    Self-documenting code only documents what the code does, not why it does it. I can look at a well written method that populates a list with random elements from another list and go “I know what that does!” but reading the code doesn’t tell me the reason this code was written or why alternatives weren’t chosen.

    In the case of Rust, it goes even a step further when working with unsafe code. Sure I know what invariants need to be held for unsafe code to be sound, but not everyone does, and it isn’t always clear why a particular assumption made in an unsafe block (the list has at least 5 elements, for example) can be made soundly.

    • RustySharp@programming.dev
      link
      fedilink
      arrow-up
      7
      ·
      11 months ago

      …what the code does, not why it does it

      This is my issue with “it’s self documenting code!”. I’m a maintenance coder. I deal with people’s code long after they’re dead (or ragequit). Some are for control systems.

      if (waterPressure_psi > 500) raise PipeMayBurstException. Okay, we’re dealing with water pressure, in psi unit, and if it’s too high, it may break the piping. Self documenting!!

      Except that our pipes are rated for 1000psi. SO WHY THE 500?! Do we have one or two sites - out of hundreds - with lower rated pipes? I can double performance if we raise the threshold to 700, well within the safety tolerance, but AM I GONNA KILL SOMEONE when they upgrade to our latest controller??

      • glue_snorter@lemmy.sdfeu.org
        link
        fedilink
        arrow-up
        3
        arrow-down
        1
        ·
        edit-2
        11 months ago

        Ugh, a Magic String (I call it that whatever the type)

        FACILITY_MAX_PRESSURES = {
            "Durham": 1000,
            "Ipswich": 500,
            "Calne": 750,
        }
        
        max_pressure = list(sorted(
            FACILITY_MAX_PRESSURES.values()
        ))[-1]
        
        if water_pressure > max_pressure:
            blah
        

        Obviously it should really pull from facility management, but that’s a bunch of moving parts where a constant is how you’d prefer the code to work

        Tbh it starts to look better to just define a constant and comment it.

        • RustySharp@programming.dev
          link
          fedilink
          arrow-up
          4
          ·
          edit-2
          11 months ago

          Tbh it starts to look better to just define a constant and comment it.

          Well… if (waterPressure > MAX_PRESSURE_BEFORE_YOU_FLOOD_THE_WHOLE_TOWN_OF_IPSWICH_AND_CALNE) is pretty self-documenting. No comments needed.

          • drdnl@programming.dev
            link
            fedilink
            arrow-up
            3
            ·
            11 months ago

            Although a bit long, I do like this almost impossible to ignore example of self documenting code :)

      • Double_A@discuss.tchncs.de
        link
        fedilink
        arrow-up
        1
        ·
        edit-2
        11 months ago

        That’s because they are usuing magic numbers. If e.g. the 500 was MaximumPipeRating * SafetyMargin it would already be better.

    • Double_A@discuss.tchncs.de
      link
      fedilink
      arrow-up
      1
      ·
      edit-2
      11 months ago

      If that list code is in a function called “PickRandomQuizQuestions” you would also know why it does that.

      • TehPers@beehaw.org
        link
        fedilink
        English
        arrow-up
        1
        ·
        11 months ago

        I encourage you to find a name for this function that describes why there is a second inner function. One restriction - the name of the function must be run (that’s what the trait being implemented calls it, you can’t rename it).

        Sure, you can call the inner function run_inner_to_fix_rustc_issue_probably_caused_by_multiple_fnmut_impls but is that really any better than using two forward slashes to explain the context?